04 night train, cuts out and dies

Discussion in 'Softail Models' started by mgierman39, Apr 16, 2011.

  1. mgierman39

    mgierman39 Member

    47
    0
    0
    Here's the senerio, at idle the rpm will bump up a little and when you give it gas it dies, restarts ok. Got to love it when it happens at the light. Also when shifting gears then gasing it, it cuts out and dies, stay off the clutch and it will bump start. Happens any were from every couple of rides to a few times a ride. Took the bike in to the local HD dealer, they said intake leak and replaced parts. Took it back 2 more times but it wount do it at the dealer. Spending money and not fixed. Most of the time it will not throw a DTC code.

    Replaced fuel regulator, Fuel filter, no intank fuel leak, tested temp sensor, cleaned off and tested Crank sensor (old Style).
     
  2. Slapp

    Slapp Junior Member

    458
    28
    3
    check cylinder heads and exhaust mainfolds for leaks, sounds like it could be timing issues as well. My want to look at the injectors to see if they are firing properly. Good Luck and keep us posted.
     
  3. Hoople

    Hoople Account Removed

    7,198
    0
    34
    And when it does, what is it.
     
  4. mgierman39

    mgierman39 Member

    47
    0
    0
    It varies between 4 codes P0261 - P0264, but most of the time no code.

    ===========================================================

    Checked spark plugs, they look clean. At idle wiggled the wires around the injectors, idle stayed even.
     
    Last edited by a moderator: Apr 16, 2011
  5. mgierman39

    mgierman39 Member

    47
    0
    0
    Is it ok to pull an injector to see the spray pattern, to check for clog or low flow?
     
  6. mgierman39

    mgierman39 Member

    47
    0
    0
    Tbones, It is EFI, I cleaned the IAC, and TPS. The IAC will cycle, I will test the TPS.
     
  7. SpringerSteve98

    SpringerSteve98 Active Member

    187
    26
    0
    To check and see if there is still an intake leak try spraying some WD-40 around the intake manifold (both carb side and head side) while the bike is running. If there is any change in idle while you're spraying, there is still a leak. Its a good idea to have a fire extinguisher handy while you're doing this just in case.
    It kinda sounds to me like it might be idling a bit rich and loading up on you, then when you give it a bit of gas its flooding? I'm taking a stab in the dark there. Is there any black smoke from the exhaust? Have you done any exhaust/fuel system mods?
     
  8. mgierman39

    mgierman39 Member

    47
    0
    0
    Couldnt find any intake leaks, The only mod thats been done is 2 -1 vance and hines and down load when I bought the bike in 04. No black smoke. I havent had a chance to check the TPS yet. Doesent smell like its running rich or flooding, plus the spark plugs look clean.

    How do I test the TPS, Isnt it similiar to a reostat and check the resistancce as it turns? or does it need power.
     
    Last edited by a moderator: Apr 16, 2011
  9. SpringerSteve98

    SpringerSteve98 Active Member

    187
    26
    0
    Yea, i'd say the TPS would be the next thing to look into. Wouldn't hurt to check the o2 sensors either
     
  10. SpringerSteve98

    SpringerSteve98 Active Member

    187
    26
    0
    To check your TPS break out the multimeter. I think you need the ignition switch on, but the bike doesn't have to be running. Hook the multimeter up to pin #30 and a solid ground (pin 16). Observed voltages should be from .2 - .4 at idle, to 4.6 - 4.95 at wide open throttle.

    I forgot to add... Be sure to look for a steady increase as you twist the throttle slowly. Note any sudden drops or spikes.
     
    Last edited by a moderator: Apr 16, 2011