03 Sporty 1200C

Discussion in 'Electrical' started by mike1965, Apr 26, 2013.

  1. mike1965

    mike1965 New Member

    2
    0
    0
    Hello everyone. New to the harley world. I purchased A 03 sporty 1200C at the end of last season. Spent the winter getting ready for now. You can see a check engine picture it has never illuminated under any condition. The bike runs other lamps on the dash work. Is it supposed to work or all the spedos just manufacted that way ? Thanks
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Welcome to The Forum, if your engine light is staying on you have a code stored have a look here Harley Codes - Fuel Moto
     
  3. mike1965

    mike1965 New Member

    2
    0
    0
    You may have read my post incorrectly. The light doesnt and never comes on. The answer I am looking for is this was it uesd on my model bike or is all the spedos just manufacted that way ?
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34

    Mike, I am 99% sure that the check engine light was only used on the 1200S model for 2003.
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Meaning that your speedo has the light but it is not used or functional.
     
  6. tourbox

    tourbox Senior Member

    1,311
    68
    54
    Question for the masses. If it is a carb. bike would the CEL even come on? IMO it wouldn't,please correct me if I'm wrong.
    tourbox
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    TourBox, According to the service manual, a carb 1200S has a CEL and it does come on when a code is stored. But it has a pretty limited number of possible codes. Take a look at the attachment. Diags are for the ignition control module.
    I assume the speedo is the same for a 1200C. But the light just never comes on.
     

    Attached Files:

  8. tourbox

    tourbox Senior Member

    1,311
    68
    54
    Thanks Hoople, that answers my question. It did say it should on as normal when the key is turned on.
    I saved the PDF in my Diag. file.
    tourbox