03 Road King Died

Discussion in 'Touring Models' started by greenhealer, Jul 10, 2010.

  1. greenhealer

    greenhealer Member

    6
    0
    0
    I was riding today had wnet about 60 miles and everything was fine.I took off and went about 1/4 of a mile and my bike just died like it was out of gas...no spittin or coughing just dead. I tried starting it and it just turns over, fuel pumps running when you turn the switch but it isnt getting any spark.My first thought is the coils is this possible or should I check something else? Any info would be most helpful.
    Thanks in advance, Joe
     
  2. fisherman124

    fisherman124 Active Member

    293
    0
    1
    sit back take a look around.good people here to give you advice .till then try the self help section good luck this is a nice site
     
  3. revok1200

    revok1200 Active Member

    209
    28
    2
    Had an 01' XLC, that displayed similar symptoms. I could ride some days for a full tank of gas with no problems, stop fill it up and then take off again and go a few miles and it would just die. Just like someone turned the key off while you were ridin. I could wait 5-10 min or sometimes more and then it would start right up and go without a problem for hours or sometimes days.

    Messed around for a 2 weeks, checked coil, plugs, fuel, everything I could think of. I finally figured out it was connected to temperature and that led me to the ignition module. Changed out the old module for a new and never had the problem again.

    When it got hot something in the circuit was opening and shutting the bike down, it would cool and then run just fine.

    Not sure if this helps but it may be a similar problem?: I hate electric issues. small3d012:
     
  4. greenhealer

    greenhealer Member

    6
    0
    0
    Can the Crank shaft sensor go bad while your riding and shut your bike down?
     
  5. glider

    glider Veteran Member

    25,464
    108
    44

    Sure can. It furnishes vital info to the ECM so it can send out the proper signals to the various systems on the bike.
     
  6. greenhealer

    greenhealer Member

    6
    0
    0
    Any tips on getting the Crank shaft sensor out?
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
  8. roadking01

    roadking01 Member Contributor

    97
    6
    0
    I just went thru this on my 01 RK, somtimes it would die while riding and sometimes it just wouldn't start until it finally stopped firing up all together, I replaced the cks and problem fixes.
     
  9. greenhealer

    greenhealer Member

    6
    0
    0
    I whent out and took it off where it has the allen screw and pulled it out and the other side runs down along the frame and back towards the side cover inside of like a wiring harness.. so does that go clear back there and plug in someplace? And a side not i cleaned the end off real good put it back tightend it down and she started right up so i know what my problem is for sure.
     
  10. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Good call and finding the problem, but replacing the CKP module is only $40 and you do NOT want the problem to crop up again, as Smitty' advice is cetainly the ranking officer in charge here...:s