03 Road King Clutch problem

Discussion in 'Touring Models' started by shovelhed, Oct 25, 2011.

  1. shovelhed

    shovelhed Member

    10
    0
    0
    Since I changed my bars and cables I have to constantly adjust my clutch. I have 6000 miles since change. Any thoughts on what could be my problem?
     
  2. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    What exactly do you mean by "constantly?" Every day? Every thousand miles?

    Are you positive you got the correct cables when you changed your bars?
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    What clutch set up do you have and is this chain or belt primary, just too many questions will need more info,, But I would guess wrong length clutch cable
     
  4. shovelhed

    shovelhed Member

    10
    0
    0
    I got a complete kit 16" bars and all cables. clutch cable is 74". Stock wet clutch and chain primary. need to adjust about every 100 miles.
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Community try this
     
  6. shovelhed

    shovelhed Member

    10
    0
    0
    this is how i always adjust my clutch. could i have a problem with balls and inner ramp set up?
     
  7. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    43
    Just a quick question. Are you adjusting because of play in the cable or slipping?
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Yes and Yes, Try starting over again with a cold clutch and check your cable swing the bars end for end to see if the cable is binding
     
  9. shovelhed

    shovelhed Member

    10
    0
    0
    play in cable. after adjustment.clutch engages where it shoud but play in cable gradually changes until clutch engages right off the grip
     
  10. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    43
    I have to agree with Jack. It sounds like your cable is binding in some way. Or it's the way you have it routed. It could be getting bound up, and then when you go to adjust it, the cable relaxes when you loosen it.

    Are you adjusting with the handle bars straight or turned to the left/right?