03 Dyna low rider electrical demon

Discussion in 'Electrical' started by Dynalow03, Apr 12, 2016.

  1. Dynalow03

    Dynalow03 Member

    18
    3
    2
    Hello new to the site but hoping I can get a little help.
    I have an 03 Dyna low rider that I bought with a few minor things to be repaired. Down to one which I thought was pretty straight forward but maybe not. I have a speedometer/odometer along with a check engine light along with the turn signal cancelling shut off that has issues after 15 minutes of riding or so. I did some research and it looked like the speed sensor so I just installed a brand new one and went on a ride. All was good until 10-15 minutes onto it and once again everything starts to shut down.
    Bike runs great but speedometer/odometer quits and check engine blinks on and off.
    Looking for any help out there. I did order another sensor from Harley in case this one may be defective.
    Thanks
    Jim
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
  3. Dynalow03

    Dynalow03 Member

    18
    3
    2
    I'm on it now
    Thanks
     
  4. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
    Does your bike have a maxi-fuse or a main circuit-breaker? If the latter, the OEM CBs were undersized at least on the baggers..You might want to trade yours out if the bike is so equipped for a new breaker of the same size, or the next size up (from 30 to 40, or 40 to 50).

    If your bike has a maxi-fuse, then on to plan B!!!

    Cheers,

    TQ
     
  5. Dynalow03

    Dynalow03 Member

    18
    3
    2
    Not sure on the fuse but hood to know can't have too many ideas as I'm stumped right now.
     
  6. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,593
    103
    296
    As Bernie suggested, start with checking for any codes.
     
  7. Dynalow03

    Dynalow03 Member

    18
    3
    2
    I pulled the seat and located the electrical port connection. I see no numbers anywhere on it? I can make a jump wire and through a process of elimination probably figure it out. I just want to make sure it will not be an issue to guess at it so it does not short something out?
    Thanks for all the input
     
  8. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    So are you saying you can not check codes through speedometer?
     
  9. Dynalow03

    Dynalow03 Member

    18
    3
    2
    Yes I can but it says bank 2 SEt and bank 8 SEt the rest are clear
     
  10. tourbox

    tourbox Senior Member

    1,309
    68
    54
    I believe those are speedo/tach codes only. The codes through the speedo are different from the ECM codes, as in blinking light for the early models.
    I am not home for a few more days but will check my stash of codes when I get back if nothing resolved. Have you checked the archives for hooking up the pins on the Data port?
    tourbox

    Jumped the gun. I see some already posted the procedure. The #'s are on the plug,wire side, but real small.
    tourbox
     
    Last edited by a moderator: Apr 14, 2016