0122 dtc

Discussion in 'Electrical' started by FLST, Sep 21, 2011.

  1. FLST

    FLST Active Member

    248
    28
    4
    A few weeks ago my check engine light indicated an historical code. I checked and discovered 0122-TPS open/low. Since it was not an active code I cleared it and have taken a number of rides since with no indication of a code. Yesterday the same code returned.
    The manual procedure tells how to check the TPS, but is not very specific. I don't know where to use the meter probes and do not want to start poking around until I am sure of what I am doing. I have an auto-ranging multi meter but no break out box. Can I do the recommended test (pp5-81 in Electrical Diagnostics Manual) without special equipment, and where do i put the probes to obtain the proper readings?

    2005 FLSTCI
    16,300 miles
    Stage One
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. FLST

    FLST Active Member

    248
    28
    4
    Thank you Glider. I should have looked there first. Will IAC have to be reset just from checking the values? I have been looking at following the flow chart in the manual, but don't want to get in over my head. What will happen if I simply ignore this code and ride. Will that foul something up or strand me?
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    It shouldn't effect the IAC. The parameters for that are stored.

    If you ignore the light and ride and it is a TPS problem, a lot of systems on the bike rely on the input from the TPS so many things will not work as they were designed to . It's not difficult to diagnose or replace.
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Very Very rarely will a problem go away and stay away all by itself. Conditions have to be pretty bad for the built in diagnostics to throw a code. If you look and test with a meter I am sure you will find something.

    Since the DTC is an "open/low" code, you stand a very good chance the pigtail lead (wire harness) from the TPS to the frame has a fracture. There are lots of ways to check the circuit. One is using the continuity beeper on your Fluke meter. Perform a wiggle test between the TPS connector and ECM plug. Do not use auto-ranging on your meter. Use a fixed range when checking the individual wires. (200 ohm)
    The IAC won't be effected just from checking with your meter. At least not on a 2005.
     
  6. FLST

    FLST Active Member

    248
    28
    4
    I'm ready to give that a try. Do I have to pull the ECM connection. The "TP Sensor Circuit" shows three points in the ECM where the wires go to from the TPS. Am I going to be checking each individual wire for continuity? How do I tell which terminals in the ECM are the correct ones? Are they numbered? Thanks.
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Having the Exact service manual and schematic for your bike is an absolute must. The schematic shows what each pin does. The ECM connector itself is labeled with ROW starting and ROW ending numbers. (The connector in MY case is 36 pin. So #1 #18, #19 and #36 are labeled)

    You can buy separate Delphi female and male pins (listed in the parts manual) which will help in a BIG way when troubleshooting these types of problems. You can make up some test leads which removes a lot of the grief and problems holding test leads in place during wiggle tests.. Do not insert homemade paperclips into the ECM female sockets. You will ruin them if you do.

    ALWAYS first disconnect the battery. NEVER pull the ECM connector while the battery is hooked up.. This will also give you a chance to inspect the ECM connector completely (both sides) and apply the proper lube (not dielectric grease) to the female & male pins.

    You can test the 3 leads one at a time or all three at one time by series connecting them, but in this case I would opp for 1 lead at a time. Be aware some test meter continuity beepers are buffered. Use the 200 ohm scale. Test your meter FIRST for buffer speed by scraping a file with the ohm meter to see if it will in fact catch a milli/second break in continuity. Clip one test lead to the file and scape the other lead across the file. You should hear a beep EACH time the lead hops across a tooth on the file. If your meter can not detect a very short time period break, it will not work for this troubleshooting session. Most good quality meters will detect a continuity break of 50 micro seconds or longer. That is way to short for humans to detect so the beeper & display will be buffered using a pulse stretcher to 100 milliseconds (1/10 second) so us slow humans can sense there is a problem. :)
     
  8. FLST

    FLST Active Member

    248
    28
    4
    Good information, Hoople. Thank you. I do have the exact electrical diagnostics manual but am new to this electrical troubleshooting stuff and want to go carefully. Am still working on understanding the schematics but the more I pour over them the brighter the light gets. Maybe someday I'll "get" it. lol.
    Till then I'll follow your instructions and get back when I have some results.
     
  9. Hoople

    Hoople Account Removed

    7,198
    0
    34
    There is nothing wrong with that. Here is the part number for the special lube for low current/voltage gold plated pins and sockets.
    Part No. 99861-02 - Nyogel 760G
     
  10. FLST

    FLST Active Member

    248
    28
    4
    Thanks for the part number. I'll get some of that lube and I want to run down those Delphi pins to make some test leads. May take a couple of days. I'll let you know the results, or be back before testing if I run into something I'm not sure about.