007 Dyna Low Rider

Discussion in 'Dyna Models' started by dyna 007, Nov 10, 2008.

  1. dyna 007

    dyna 007 Member

    5
    11
    0
    My 007 Dyna starts great and seems to run great at times. but every now and then it acts up, the idle slows way down at a stop sign and sometimes stalls. It back fires when gearing down and runs flat. I know it;s running lean,but the engine light never comes on, does any buddy have the same problem, it;s not all the time.
     
    Last edited: Nov 10, 2008
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100
    What do you mean by "engine light does not come on at all"? Even with just the key on - no light?

    Still check for trouble codes:

    04-07 HD DTC Codes and Activation - Harley Davidson Community

    If no historic codes, check for leaks on the intake side. Spray WD40 on the intake piping when the bike has just been started (fairly cold). BE CAREFUL - FLAMMABLE. You are checking for an intake leak, so if the engine breaths in the WD40 you will tell.

    If no intake leaks, try wiggling the wires to the injectors about an inch or so from the plugs.

    Let us know what you find.

    TQ
     
  3. dyna 007

    dyna 007 Member

    5
    11
    0
    The engine light functions the way it is supost to, just meaning it does not come on when it;s running rough.
     
  4. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100
    Got to thinking about this some. Does this happen when the gas tank is at or below 1/2 full? Do you know if the fuel pump is inside the tank?

    TQ
     
  5. dyna 007

    dyna 007 Member

    5
    11
    0
    Yes the fuel pump and regulator are both in the tank.
     
  6. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100