Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

Rpm or idle running high

Sportster Models

Reply
 
Thread Tools Display Modes
Old Mar 14th, 2011, 03:05 AM     #1
Start The Engine
Ride: 2011 Ultra Classic Limited
 
jterby's Avatar
 
Join Date: May 16th, 2008
Location: Cypress, CA
Posts: 27
My Mood: My Mood
jterby is an unknown quantity at this point
Rpm or idle running high

Hi guys,
I have a question about my idle or rpms staying high after rideing around and maintaining the same speed for a while. As an example, it happens quite a bit when I get off the fwy having rode for about 15-20 minutes at high fwy speeds. I get off the off ramp, down shifting like I normally do to a stop and the idle in 1st gear at stop stays very high, as if the throttle is stuck. I don't really know how to describe it other than that. I think I first noticed it when riding down a big hill with my HOG group. I had the bike in 2nd gear, because we were going slow and the hill was steep. It was for an extended period of at least 15 minutes. I noticed letting off the throttle, using the engine and gear to slow me or retard my speed, instead of hitting the brakes to much, that it was still moving like I had the throttle twisted more. I've checked & rechecked the twisty, throttle lock nut that comes on sportsters(poor mans cruise control) in case it was holding the throttle open or something. But, I've backed it all the way off or out, and I never use that thing, so I'm at a loss as to what it might be. I was concerned it was my Dobeck TFI, running the rmps somehow, but I was doubting that. My friends thought maybe my throttle cables were the issue. Like, maybe they need an adjustment or are going bad somehow. I know whenever my bike acts weird, someone here on the forum usually knows all about it, soooooooooo....I'm asking for advice first. Let me know what you guys think it may be.

Thanks,

John
jterby is offline   Reply With Quote
Old Mar 14th, 2011, 10:10 AM     #2
Contributor
Ride: 0
 
Join Date: Jul 4th, 2010
Posts: 4,076
dbmg will become famous soon enoughdbmg will become famous soon enough
Re: Rpm or idle running high

Check to see if throttle cables are free at grip and throttle body. Then check to see if air cleaner is installed properly. Next would be to see if a slight vacuum leak at throttle body to intake manifold. Do you have a check engine light coming on while riding???
dbmg is offline   Reply With Quote
Old Mar 14th, 2011, 10:34 AM     #3
Account Removed
Ride: 2009 Dyna Low
 
Join Date: Aug 16th, 2009
Posts: 7,235
Hoople will become famous soon enoughHoople will become famous soon enough
Re: Rpm or idle running high

I would also get a can of CRC mass air flow sensor cleaner, and shoot some directly into the IAC bypass hole in the throttle body. You may get lucky and it be a sticky IAC stepper.

And like was already mentioned, check for historical codes.
Hoople is offline   Reply With Quote
Old Mar 14th, 2011, 01:27 PM     #4
Contributor
Ride: FLHR 09/103"
 
BUBBIE's Avatar
 
Join Date: Oct 15th, 2008
Location: AZ, S.East corner/Western WA.
Posts: 4,462
My Mood: My Mood
BUBBIE has a spectacular aura aboutBUBBIE has a spectacular aura about
Re: Rpm or idle running high

WHEN does it work Right?
OR does it keep the fast idle all the time?

If it is hitting the FAST IDLE after leaving off the throttle does IT come down on its own? after a while stopped?...

Have YOU done anything to the bike Right BEFORE it had this problem? Like adjusted the throttle cable?

signed....BUBBIE
__________________
*************************
Quite Often I am Right so Forgive me when I'm WRONG!!!.......
BUBBIE is offline   Reply With Quote
Old Mar 15th, 2011, 10:00 PM     #5
Start The Engine
Ride: 2011 Ultra Classic Limited
 
jterby's Avatar
 
Join Date: May 16th, 2008
Location: Cypress, CA
Posts: 27
My Mood: My Mood
jterby is an unknown quantity at this point
Re: Rpm or idle running high

Thanks for the quick responses! Dbmg: I'll have to check the throttle cables, more. Just a quick look I didn't see any problems(yet). I have seen the check engine light come on while running, not always while riding. Sometimes it's come on at idle. Always goes right out, but I was concerned. I did just clean & recharge myK&N air filter, but it was going on before the cleaning. Hoople: I will have to consult my service manual abut the IAC bypass hole. But it's another great tip.I'm also unaware how to view the codes, hopefully that also in the service manual. Bubbie: it works correctly most of the time. Just seems to happen when I've been running at a fairly wide open throttle maintaining higher speeds for a while(fwy) or longer stints(catching all green lights) on the streets at a speed of about 45 or more. It always seems to come back to a normal idle after getting back into first gear when stopped, or when I start going again in 1st. So, it does come down on it's own. I've never adjusted the throttle cables, other than maybe the dealership during a service visit. But that has been quite a while. I didn't do any adjustments to anything before this.
Thanks again for the great tips. I hope I can resolve this without a visit to my dealership.

John
jterby is offline   Reply With Quote
Old Mar 15th, 2011, 10:26 PM     #6
Play The Throttle
Ride: 2009 Dyna Super Glide Custom
 
cyborg's Avatar
 
Join Date: Apr 8th, 2009
Location: South Jerzey
Posts: 216
My Mood: My Mood
cyborg is an unknown quantity at this point
Re: Rpm or idle running high

Quote: Originally Posted by jterby View Post
Hi guys,
I have a question about my idle or rpms staying high after rideing around and maintaining the same speed for a while. As an example, it happens quite a bit when I get off the fwy having rode for about 15-20 minutes at high fwy speeds. I get off the off ramp, down shifting like I normally do to a stop and the idle in 1st gear at stop stays very high, as if the throttle is stuck. I don't really know how to describe it other than that. I think I first noticed it when riding down a big hill with my HOG group. I had the bike in 2nd gear, because we were going slow and the hill was steep. It was for an extended period of at least 15 minutes. I noticed letting off the throttle, using the engine and gear to slow me or retard my speed, instead of hitting the brakes to much, that it was still moving like I had the throttle twisted more. I've checked & rechecked the twisty, throttle lock nut that comes on sportsters(poor mans cruise control) in case it was holding the throttle open or something. But, I've backed it all the way off or out, and I never use that thing, so I'm at a loss as to what it might be. I was concerned it was my Dobeck TFI, running the rmps somehow, but I was doubting that. My friends thought maybe my throttle cables were the issue. Like, maybe they need an adjustment or are going bad somehow. I know whenever my bike acts weird, someone here on the forum usually knows all about it, soooooooooo....I'm asking for advice first. Let me know what you guys think it may be.

Thanks,

John
I have have the same problem after installing Dobeck TFI on my 09 Dyna,,,, everybody said i was crazy. Now your the third or forth one on here that`s had this same problem. SO i guess i`m not crazy after all.
__________________
Gun Control, Means hitting your Target.
cyborg is offline   Reply With Quote
Old Mar 15th, 2011, 10:52 PM     #7
Start The Engine
Ride: 2011 Ultra Classic Limited
 
jterby's Avatar
 
Join Date: May 16th, 2008
Location: Cypress, CA
Posts: 27
My Mood: My Mood
jterby is an unknown quantity at this point
I found out how to get the codes from my bike. The PSSPt6 listed below:
P- no rsp
S- none
SP- none
Pn 68924-07
S- none
Pn 67037-08
t- no rsp
6- no rsp

* this is on my 2008 Nighster with a Dobeck TFI installed.

================================================

P.s. My TFI has been installed for months now with no issues other than making the bike run better. I'll be surprised or bummed out, if it's this device. Seems like throttle stuff.

Last edited by Dr. Dolittle; Mar 15th, 2011 at 11:03 PM. Reason: merged posts
jterby is offline   Reply With Quote
Old Mar 15th, 2011, 11:14 PM     #8
Account Removed
Ride: 2009 Dyna Low
 
Join Date: Aug 16th, 2009
Posts: 7,235
Hoople will become famous soon enoughHoople will become famous soon enough
Re: Rpm or idle running high

Strange that there are no historical codes since you did say you saw the check engine light come on. (Could be you went through 50 key cycles with no engine issues)

When you get off the interstate & the idle is high,,, if you were to power it off and restart the bike, does the idle calm down or does it resume the high idle.

Would help to know how high the RPM was, but you have no tach. (?)
Hoople is offline   Reply With Quote
Old Mar 18th, 2011, 01:20 AM     #9
Start The Engine
Ride: 2011 Ultra Classic Limited
 
jterby's Avatar
 
Join Date: May 16th, 2008
Location: Cypress, CA
Posts: 27
My Mood: My Mood
jterby is an unknown quantity at this point
Hoople: I'll have to remember to try shutting it off and restarting. I'll write back if I find anything. Im sure the no tach thing, doesn't help me determine this issue as fast. When it happens I keep forgetting to look down at the cables near the engine and see if that is sticking open. I'm usually in the dark riding the FWYs too & from work, so it'll be had to tell. thank you so much for the input.

Last edited by NEWHD74FAN; Mar 18th, 2011 at 02:26 AM. Reason: Merge Post
jterby is offline   Reply With Quote
Old Mar 18th, 2011, 02:32 AM     #10
Retired Moderators
Ride: 2004 Sportster XL1200R
 
NEWHD74FAN's Avatar
 
Join Date: Aug 24th, 2008
Location: Camarillo, CA
Posts: 8,275
My Mood: My Mood
NEWHD74FAN is an unknown quantity at this point
Re: Rpm or idle running high

Jterby, Hoop brought up a good point...also when shutting down the bike, do not blip the throttle...just close throttle, use kill switch and THEN turn ignition off. This allows the ECM to remember all the "idle", throttle position and store the DTC status. There was also a download update if memory serves for some of the 2007 or 2008 models regarding an idle issue, so check with your H-D dealer for Service Bulletin regarding this.
__________________
* Please click "Self Help Tips" tab for service tips, diagnostic codes & such * ;o) * Please click "Search" tab and keywords to find related threads *
NEWHD74FAN is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle a little high xdanman Touring Models 5 Sep 3rd, 2010 06:09 PM
Hot high idle TRichardson Engine, Fuel and Exhaust 1 Jul 9th, 2009 06:56 AM
High idle Caper Engine, Fuel and Exhaust 25 May 19th, 2009 06:31 AM
2008 High Idle glider. Tech Tips, Instructions and Service Bulletins 0 Jul 6th, 2008 07:46 AM
Intermittent High Idle glider. Tech Tips, Instructions and Service Bulletins 0 Jul 21st, 2007 08:20 PM