Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

07 883L sportster Problem!!!!

Sportster Models

Reply
 
Thread Tools Display Modes
Old Mar 31st, 2009, 03:27 PM     #1
New Family
Ride: 2007 Sportster L
 
Join Date: Mar 31st, 2009
Location: Bernville,PA
Posts: 7
HarleyRyder74 is an unknown quantity at this point
07 883L sportster Problem!!!!

I just got it 4 months ago. LOVE IT!! Untill i washed it 4-5 days ago. A day later i started it up. Everything is fine. Then 2 days later i want to start her up again and nothing.............when you turn key to acc it shows time on guage......when you turn to ignition ... it drowns the battery no noise what so ever..........so i checked fuses, I jumped battery then it was trying to crank but no start. And it does start on 1-2 cranks bike is like brand new it only has 4500 miles on it. I never had any problems.

Plzzzzz help.

Thanks, Gary
HarleyRyder74 is offline   Reply With Quote
Old Mar 31st, 2009, 03:54 PM     #2
Warming The Wheels
Ride: 2008 XL 1200 Nightster
 
Crambo's Avatar
 
Join Date: Jun 15th, 2008
Location: Spain
Posts: 134
My Mood: My Mood
Crambo is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

Hi Gary, Welcome to the forum.
Here's a link to a previous thread with similar battery problems after the bike had been recently washed or ridden through rain, hope this helps.

XL883C Odd Noise - Page 2 - Harley Davidson Community (XL883C Odd Noise)
Crambo is offline   Reply With Quote
Old Mar 31st, 2009, 04:07 PM     #3
New Family
Ride: 2007 Sportster L
 
Join Date: Mar 31st, 2009
Location: Bernville,PA
Posts: 7
HarleyRyder74 is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

Thanks for your reply................makes sense.........So would i need a new relay switch? Or what part?

Thanks again!
HarleyRyder74 is offline   Reply With Quote
Old Mar 31st, 2009, 04:22 PM     #4
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: 07 883L sportster Problem!!!!

Try removing, cleaning and refasten the battery terminals on the battery. More than likely the reason it didn't start with the jumpers is low voltage to the ECM. It needs at least 9 volts to fire things off.

Last edited by glider; Mar 31st, 2009 at 06:43 PM. Reason: spelling
glider is offline   Reply With Quote
Old Mar 31st, 2009, 06:30 PM     #5
New Family
Ride: 2007 Sportster L
 
Join Date: Mar 31st, 2009
Location: Bernville,PA
Posts: 7
HarleyRyder74 is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

thanks man gonna try it now.
HarleyRyder74 is offline   Reply With Quote
Old Mar 31st, 2009, 08:17 PM     #6
Retired Moderators
Ride: 2004 Sportster XL1200R
 
NEWHD74FAN's Avatar
 
Join Date: Aug 24th, 2008
Location: Camarillo, CA
Posts: 8,276
My Mood: My Mood
NEWHD74FAN is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

I know a little after the fact, but when washing your bike, no running water above the level of the lower side covers and around the starter/electrical bay. Might also want to use a bike blow dryer to evaporate and rid your bike of any "standing water".

There are several theads regarding cleaning and preserving methods and products. Use the <search> tab at the top of the page or go to maintenance section...a lot of good stuff in there. Make sure you use dielectric grease in all the contacts you expose, after checking & cleaning to prevent long term corrosion.
__________________
* Please click "Self Help Tips" tab for service tips, diagnostic codes & such * ;o) * Please click "Search" tab and keywords to find related threads *
NEWHD74FAN is offline   Reply With Quote
Old Mar 31st, 2009, 08:50 PM     #7
Community Guru Wannabe
Ride: 2007 softail fxst
 
wildspirit97's Avatar
 
Join Date: Sep 12th, 2007
Location: Washington
Posts: 1,088
My Mood: My Mood
wildspirit97 is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

Washing the bike may just be a coincidence. I would make sure your battery is good before going too far. an '07 with 4500 miles on it means it's been sitting a lot, and if the battery wasn't taken care of it could be bad.
wildspirit97 is offline   Reply With Quote
Old Apr 1st, 2009, 09:14 PM     #8
Warming The Wheels
Ride: 04sportster
 
oseita's Avatar
 
Join Date: Mar 20th, 2009
Location: Elberton, Ga
Posts: 97
My Mood: My Mood
oseita is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

I had the same problem with my '04 883 after riding in rain. When I would park it it would not restart unless I jumped it off. I had a bro look at it and he explained what glider said. He took off the battery terminals, cleaned them and the contacts, and then told me to go to autozone or any parts store and get some battery terminal grease and coat them. No more problems!
oseita is offline   Reply With Quote
Old Apr 2nd, 2009, 12:36 AM     #9
New Family
Ride: 2007 Sportster L
 
Join Date: Mar 31st, 2009
Location: Bernville,PA
Posts: 7
HarleyRyder74 is an unknown quantity at this point
07 883L sportster Problem!!!!

well i took off the battery....terminals are fine very clean and they were dry. Then i charged it...........now when i hit start button.......a louddd click from the starter i guess like something is preventing it to turn over.....I highly doubt its the starter gone bad................Im am sooooo

well before the water deal my battery had a solid charge like a new battery. Thanks for replying

Thanks for the info lol Im used to my dresser I used to always hose that baby and never a problem............Sportster is to exposed i guess

Last edited by glider; Apr 2nd, 2009 at 09:08 AM. Reason: merged
HarleyRyder74 is offline   Reply With Quote
Old Apr 2nd, 2009, 12:51 AM     #10
Retired Moderators
Ride: 2004 Sportster XL1200R
 
NEWHD74FAN's Avatar
 
Join Date: Aug 24th, 2008
Location: Camarillo, CA
Posts: 8,276
My Mood: My Mood
NEWHD74FAN is an unknown quantity at this point
Re: 07 883L sportster Problem!!!!

Could the cylinders be full of water or oil? Point the bike towards a mirror or garage door to view the headlamp brightness while you crank the engine, if the light dims to 1/2 brightness or goes out, your battery does not have enough reserve to crank the starter 160A or so plus have voltage be at least 10V to keep ignition module firing the plugs. You can test if some is bad, but not test if something is good, like a bad starter (too much draw), hydraulicking engine (filled cylinder or obstruction) or low battery reserve (low CCA) unless unit is totally gone.
__________________
* Please click "Self Help Tips" tab for service tips, diagnostic codes & such * ;o) * Please click "Search" tab and keywords to find related threads *
NEWHD74FAN is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sportster electrical problem?????? geno Electrical 2 Dec 7th, 2010 02:55 PM
08 sportster problem 67hat34c Sportster Models 32 Jul 20th, 2010 12:38 PM
tfi install for a 2009 sportster 883l mikes harley Sportster Models 4 Dec 14th, 2009 06:09 PM
Brake light 06 Sportster 883L? onich28 Electrical 2 Mar 15th, 2009 02:38 PM
Sportster Starting Problem Bucket Electrical 15 Apr 29th, 2008 03:50 PM