Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

fatboy problems

Electrical

Reply
 
Thread Tools Display Modes
Old Oct 17th, 2012, 02:49 PM     #1
New Family
Ride: 2000 fatboy
 
Join Date: Oct 17th, 2012
Location: jacksonville florida
Posts: 5
swampdawg is an unknown quantity at this point
fatboy problems

i have a 2000 fatboy...when riding my speedo and mileage indicator quit working and my engine lite comes on...when i slow down or come to a stop everything works again and engine lite goes out...talk to harley and they said speed sensor bad..i replaced..still doing it...now im noticing when when im not riding i can throttle the bike a lil and it does it..mileage indicator goes out and engine lite comes on...let off throttle and it works fine...any suggestions would be helpful..its driving me nuts trying to figure this out...thanks
swampdawg is offline   Reply With Quote
Old Oct 17th, 2012, 04:32 PM     #2
Contributor
Ride: 2007 Streetbob
 
Jack Klarich's Avatar
 
Join Date: Sep 25th, 2009
Location: Jacksonville, Florida
Posts: 16,329
My Mood: My Mood
Jack Klarich has a spectacular aura aboutJack Klarich has a spectacular aura about
Re: fatboy problems

Quote: Originally Posted by swampdawg View Post
i have a 2000 fatboy...when riding my speedo and mileage indicator quit working and my engine lite comes on...when i slow down or come to a stop everything works again and engine lite goes out...talk to harley and they said speed sensor bad..i replaced..still doing it...now im noticing when when im not riding i can throttle the bike a lil and it does it..mileage indicator goes out and engine lite comes on...let off throttle and it works fine...any suggestions would be helpful..its driving me nuts trying to figure this out...thanks
Quote: Originally Posted by The Tank View Post
Here is a link to how to retrieve codes from that model year.

Harley Davidson Community (00-03 HD Codes And Activation)
Welcome to The Forum http://www.hdtalking.com/archive/t-47714.html have a look here also, pay attention to connections at the battery before testing, clean and tight
__________________
CAPITAL JACK( Nuff Said, We're Burnin Daylight, Let's Ride)
Jack Klarich is offline   Reply With Quote
Old Oct 18th, 2012, 07:38 AM     #3
New Family
Ride: 2000 fatboy
 
Join Date: Oct 17th, 2012
Location: jacksonville florida
Posts: 5
swampdawg is an unknown quantity at this point
Re: fatboy problems

thanks for the info....i got the code ..only one that came up was positive battery voltage...would a bad regulator cause this problem im having...? again thanks alot for info
swampdawg is offline   Reply With Quote
Old Oct 18th, 2012, 09:45 AM     #4
Account Removed
Ride: 2009 Dyna Low
 
Join Date: Aug 16th, 2009
Posts: 7,235
Hoople will become famous soon enoughHoople will become famous soon enough
Re: fatboy problems

Quote: Originally Posted by swampdawg View Post
would a bad regulator cause this problem im having...?
Absolutely. But don't just replace the voltage regulator without cross checking the voltage with a meter. If you see the voltage above 14.85 at 2500 RPM, it needs to be replaced.
Hoople is offline   Reply With Quote
Old Oct 18th, 2012, 10:04 AM     #5
New Family
Ride: 2000 fatboy
 
Join Date: Oct 17th, 2012
Location: jacksonville florida
Posts: 5
swampdawg is an unknown quantity at this point
fatboy problems

i checked the voltage at battery..when idling it reads 13.5...when i increase throttle it jumps past 16...it maybe a dumb question but how or why would a bad voltage regulator make the speedo quit and mileage indicator go out and engine lite come on...just tryin to understand all this..
swampdawg is offline   Reply With Quote
Old Oct 18th, 2012, 11:40 AM     #6
Account Removed
Ride: 2009 Dyna Low
 
Join Date: Aug 16th, 2009
Posts: 7,235
Hoople will become famous soon enoughHoople will become famous soon enough
Re: fatboy problems

Quote: Originally Posted by swampdawg View Post
why would a bad voltage regulator make the speedo quit and mileage indicator go out and engine lite come on...just tryin to understand all this..
The circuits in a speedo could easily be damaged by exceeding their original design operating voltage. So by design, the circuits have a built in safety feature that will turn themselves off in case of over/excessive voltage. Sixteen volts is the design threshold for shut-down and throwing a code.

The stator has the ability to swing voltages past 50 volts. Something has to be put into place to protect all the downstream components.
Hoople is offline   Reply With Quote
Old Oct 18th, 2012, 12:22 PM     #7
Play The Throttle
Ride: 1992Flstf
 
lordharold's Avatar
 
Join Date: May 27th, 2011
Location: Norfolk, Nebraska
Posts: 195
My Mood: My Mood
lordharold is an unknown quantity at this point
Re: fatboy problems

just had the same exact problem code 16 on same year and model checked charging system and it was a bad voltage regulator
lordharold is offline   Reply With Quote
Old Oct 18th, 2012, 03:09 PM     #8
New Family
Ride: 2000 fatboy
 
Join Date: Oct 17th, 2012
Location: jacksonville florida
Posts: 5
swampdawg is an unknown quantity at this point
Re: fatboy problems

sorry tank...didnt know im new here..i want to thank everyone for all the feedback...i sure hope a new regulator does it...
swampdawg is offline   Reply With Quote
Old Oct 18th, 2012, 05:05 PM     #9
Moderators
Ride: 1992 Softail Custom
 
fin_676's Avatar
 
Join Date: Dec 21st, 2008
Location: Banffshire,Scotland
Posts: 4,535
My Mood: My Mood
fin_676 is on a distinguished road
Re: fatboy problems

When replacing the voltage regulator there is a wee bit of temptation to cut and splice the feed cable into the bike electrics however that can cause a weak point so always best to feed it through the bike to its destination it can be a bit of a pest but may save you from grief at a later date

Brian
__________________
I try to put my brain in gear before my hands go on the keyboard


Self Help Information and Tips - Harley Davidson Community
fin_676 is online now   Reply With Quote
Old Oct 18th, 2012, 05:22 PM     #10
Account Removed
Ride: 2009 Dyna Low
 
Join Date: Aug 16th, 2009
Posts: 7,235
Hoople will become famous soon enoughHoople will become famous soon enough
Re: fatboy problems

Quote: Originally Posted by swampdawg View Post
..i sure hope a new regulator does it...
I am sure it will. But even if it did not fix the speedo problem, it would fix your excessively high charging voltage. That needs to be addressed regardless of the speedo issue. Batteries will overheat with that kind of charging voltage. If it has water caps, check the level.
Hoople is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
92 fatboy electrical problems smitty92 Softail Models 8 May 25th, 2011 07:53 PM
CB Problems ronsatt Touring Models 2 May 22nd, 2010 09:06 AM
25K problems? rtrev64 Dyna Models 7 Apr 20th, 2010 04:53 PM
12,000 miles no problems.. Now problems formike56 Dyna Models 15 Nov 13th, 2008 03:38 PM
electrical problems on my 03 Fatboy patsox Softail Models 6 Dec 2nd, 2007 11:29 AM