Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

Problem with 09' Ultra Classic TPS?

Electrical

Reply
 
Thread Tools Display Modes
Old Nov 6th, 2010, 12:08 PM     #11
Account Removed
Ride: 2009 Dyna Low
 
Join Date: Aug 16th, 2009
Posts: 7,235
Hoople will become famous soon enoughHoople will become famous soon enough
Re: Problem with 09' Ultra Classic TPS?

Quote: Originally Posted by Grillfish View Post
I hope this solves it.
It will for a while. Great Info & what they did should really help. The thing to remember is that unless the micro motion of the connector is STOPPED (and it has not been) the problem will return in time. The contact motion must be clamped, in order to stop the wear. Gold flashing and lube helps but it only buys you time.

If I owned a TBW bike, I would eliminate that set of contacts (both male and female) all together by attaching (soldering) the wires directly to the pots. That was a very silly place to have a quick disconnect connector to start with. With the vibration of the bars and grips what else would you expect. An integrated 12" pigtail off the pots would have been a better way.

I would be willing to bet that in time, HD makes the cable and twin pot assembly as ONE and eliminate that troublesome connector altogether.

Between having 30 different 2011 models with a bunch being TBW & now the entry into CAN network systems,, their work is cut out for them.
Hoople is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 Ultra Classic CB Radio Problem zonie8541 Communications And Radio 0 Jun 30th, 2010 01:40 PM
Looking for Ultra Classic Bobcat316 Touring Models 8 Sep 9th, 2009 01:19 AM
'03 Ultra Classic cruise control problem. Harley Phil Touring Models 4 Apr 12th, 2009 07:40 AM
Will tires from an 06 ultra classic fit ok on an 06 heritage classic jebshog Wheels 1 Jul 11th, 2008 03:41 PM
'03 Ultra Classic problem Harley Phil Touring Models 3 Jun 9th, 2008 11:34 PM