Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

Lost radio display

Communications And Radio

Reply
 
Thread Tools Display Modes
Old Aug 30th, 2009, 01:53 PM     #1
Contributor
Ride: 1960 honda 50
 
Join Date: Sep 2nd, 2008
Location: Poverty Knob
Posts: 2,303
My Mood: My Mood
Redfish-Joe is on a distinguished road
Lost radio display

This was the second time this happened. The last time I was near the Harley store in Biloxi. Dropped in, left the bike running and got the service writer to check it out. Radio worked fine but no display.

Kill the bike and start it up again, everything works fine.Anyway he wrote it up and put his contact info on the work order.

He said since he had it documented I shouldn't have any problem getting it replaced/repaired where I get my bike worked on in Slidell.

It would be nice if they do accept his findings and not have to keep my bike to "reproduce" the problem.
Redfish-Joe is offline   Reply With Quote
Old Aug 30th, 2009, 02:00 PM     #2
Moderators
Ride: '11 FLSTC (Heritage Softail Classic)
 
TQuentin1's Avatar
 
Join Date: Apr 4th, 2008
Location: Summerwood in Humble, TX
Posts: 4,239
TQuentin1 is on a distinguished road
Re: Lost radio display

They are all independent dealerships, and sometime they have an attitude "if it wasn't done here, it wasn't done right". Fraid you will have to "endeavor to persevere"!

TQ
__________________

Please stop by the "The Self-Help pages."
>>Self-Help Information and Tips - Harley Davidson Community Self-Help Threads Information<< click me!
TQuentin1 is offline   Reply With Quote
Old Aug 30th, 2009, 09:32 PM     #3
Contributor
Ride: 1960 honda 50
 
Join Date: Sep 2nd, 2008
Location: Poverty Knob
Posts: 2,303
My Mood: My Mood
Redfish-Joe is on a distinguished road
Re: Lost radio display

I'll find out tomorrow.
Redfish-Joe is offline   Reply With Quote
Old Aug 30th, 2009, 09:51 PM     #4
Play The Throttle
Ride: 2006 FLHTCI
 
vtbikers's Avatar
 
Join Date: Aug 5th, 2009
Location: Vermont
Posts: 174
My Mood: My Mood
vtbikers is an unknown quantity at this point
Re: Lost radio display

I would go back to Biloxi and se if they will fix it. Its really not that far from slidell.
vtbikers is offline   Reply With Quote
Old Aug 31st, 2009, 01:11 PM     #5
Warming The Wheels
Ride: 2011/ Cross Bones
 
Cajun Ultra's Avatar
 
Join Date: Oct 28th, 2008
Location: Slidell, LA
Posts: 114
My Mood: My Mood
Cajun Ultra is an unknown quantity at this point
Re: Lost radio display

what did they find out about it ????
__________________
Don't ride in the Bayou it's wet
2003 fxdwg,2011 flstsb
Semper Fi 69-72. NRA & Louisiana PGR Member
Cajun Ultra is offline   Reply With Quote
Old Aug 31st, 2009, 04:19 PM     #6
Contributor
Ride: 1960 honda 50
 
Join Date: Sep 2nd, 2008
Location: Poverty Knob
Posts: 2,303
My Mood: My Mood
Redfish-Joe is on a distinguished road
Quote: Originally Posted by Cajun Ultra View Post
what did they find out about it ????
They got me a brand new remaned one coming. They dont service them in store.

Quote: Originally Posted by vtbikers View Post
I would go back to Biloxi and se if they will fix it. Its really not that far from slidell.
I appreciate what the service writer did for me there. It was one of those right place right time things. I have had a few issues with the store in the past.

Slidell has always treated me with respect.

Last edited by STEVE07; Sep 1st, 2009 at 01:23 AM. Reason: Joe,please use the multi-quote button
Redfish-Joe is offline   Reply With Quote
Old Sep 1st, 2009, 12:07 AM     #7
Retired Moderators
Ride: 2004 Sportster XL1200R
 
NEWHD74FAN's Avatar
 
Join Date: Aug 24th, 2008
Location: Camarillo, CA
Posts: 8,275
My Mood: My Mood
NEWHD74FAN is an unknown quantity at this point
Re: Lost radio display

Can't do better than that, a good relationship with a reputable dealer is HUGE!
__________________
* Please click "Self Help Tips" tab for service tips, diagnostic codes & such * ;o) * Please click "Search" tab and keywords to find related threads *
NEWHD74FAN is offline   Reply With Quote
Old Sep 2nd, 2009, 07:28 PM     #8
Start The Engine
Ride: 2006 Ultra Classic
 
Join Date: Aug 31st, 2009
Posts: 11
Redfide is an unknown quantity at this point
Re: Lost radio display

This happened to me while my bike was under warranty. The dealer reflashed the software in the radio and it came back and worked ever since. Its been a year now (knock on wood).
Redfide is offline   Reply With Quote
Old Sep 4th, 2009, 05:04 AM     #9
Contributor
Ride: 1960 honda 50
 
Join Date: Sep 2nd, 2008
Location: Poverty Knob
Posts: 2,303
My Mood: My Mood
Redfish-Joe is on a distinguished road
Re: Lost radio display

Quote: Originally Posted by Redfide View Post
This happened to me while my bike was under warranty. The dealer reflashed the software in the radio and it came back and worked ever since. Its been a year now (knock on wood).
I'll give them a call and see what they think. Thanks!
Redfish-Joe is offline   Reply With Quote
Old Sep 4th, 2009, 08:11 AM     #10
Community Star
Ride: 08 Ultra Classic
 
Lancer's Avatar
 
Join Date: Jun 25th, 2008
Location: Palm Bay, Fl
Posts: 505
My Mood: My Mood
Lancer is an unknown quantity at this point
Re: Lost radio display

You can do this yourself, you have to be able to burn a cd though. Here is the link to the directions and software at the Hog Tunes web site.

http://www.hogtunes.com/techzone_fil...are_update.pdf
Lancer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Display TearkessTom Touring Models 6 Oct 27th, 2010 05:08 PM
Cannot display codes...any help?? DR_DEUCE Electrical 13 Oct 24th, 2010 01:12 AM
Weird Lines on Radio Display SprChkn Touring Models 6 Sep 20th, 2010 11:08 PM
Radio does not display 06BLACKGLIDE Touring Models 5 May 20th, 2010 11:38 AM
91573-09 Chrome Display Stand installation problem dooz28 Touring Models 10 Feb 17th, 2010 10:35 PM